# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*(\d{3})(?:-?([a-z]))?\b/$1$2/gmi;t' <<< "1-0101
101
101-A
101a
"