// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)<AbstractText\b[^>]*\b[^\/]?>(.+?)</AbstractText>").unwrap();
let string = "<AbstractText/>blahThe aim of this investigation was to determine the molecular properties and provide an interpretation of the vibrational mode couplings of these two paracetamol analogues: 2-bromo-2-methyl-N-(4-nitrophenyl)-propanamide and 2-bromo-2-methyl-N-p-tolyl-propanamide. E/Z isomers, keto/enol unimolecular rearrangement and prediction of the transition state structures in each mechanism were also assessed using the Density Functional Theory (DFT). The DFT estimates a high energy gap between E and Z isomers (9-11 kcal·mol(-1)), with barrier heights ranging from 16 to 19 kcal·mol(-1). In contrast, the barrier energies on the keto/enol isomerization are almost 10 kcal·mol(-1) higher than those estimated for the E/Z rearrangement. The kinetic rate constant was also determined for each reaction mechanism. Natural bond orbital analysis and the quantum theory of atoms in molecules were used to interpret the intramolecular hydrogen bonds and to understand the most important interactions that govern the stabilization of each isomer. Furthermore, an analysis of the atomic charge distribution using different population methodologies was also performed.</AbstractText>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}