import Foundation
let pattern = #"(?s)<AbstractText\b[^>]*\b[^\/]?>(.+?)</AbstractText>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<AbstractText/>blahThe aim of this investigation was to determine the molecular properties and provide an interpretation of the vibrational mode couplings of these two paracetamol analogues: 2-bromo-2-methyl-N-(4-nitrophenyl)-propanamide and 2-bromo-2-methyl-N-p-tolyl-propanamide. E/Z isomers, keto/enol unimolecular rearrangement and prediction of the transition state structures in each mechanism were also assessed using the Density Functional Theory (DFT). The DFT estimates a high energy gap between E and Z isomers (9-11 kcal·mol(-1)), with barrier heights ranging from 16 to 19 kcal·mol(-1). In contrast, the barrier energies on the keto/enol isomerization are almost 10 kcal·mol(-1) higher than those estimated for the E/Z rearrangement. The kinetic rate constant was also determined for each reaction mechanism. Natural bond orbital analysis and the quantum theory of atoms in molecules were used to interpret the intramolecular hydrogen bonds and to understand the most important interactions that govern the stabilization of each isomer. Furthermore, an analysis of the atomic charge distribution using different population methodologies was also performed.</AbstractText>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)