#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\)\s).*"
Local $sString = "Alonso (2000) El papel del lenguaje interior en la regulación del comportamiento" & @CRLF & _
"" & @CRLF & _
"Azcoaga (1988) El papel del lenguaje interno en el proceso de conocimiento" & @CRLF & _
"" & @CRLF & _
"Caramazza (1989) On drawing inferences about the Structure of Normal Cognitive Sysytems"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")