re = /(?<=\)\s).*/m
str = 'Alonso (2000) El papel del lenguaje interior en la regulación del comportamiento
Azcoaga (1988) El papel del lenguaje interno en el proceso de conocimiento
Caramazza (1989) On drawing inferences about the Structure of Normal Cognitive Sysytems'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end