#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^.*([A-Za-z0-9]{24}).*$"
Local $sString = "/v1/api2/5eb98050122d484001708a11f" & @CRLF & _
"" & @CRLF & _
"/v1/api1/5eb98050122d484001708a11f/61b3330151e541232146bfb7/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")