#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^ *analyticsConfig\.analyticsClass = WLAnalyticsWrapper\.self"
Local $sString = "@objc (WLAppDelegate)" & @CRLF & _
"open class WLAppDelegate: LUUIBaseAppDelegate {" & @CRLF & _
"" & @CRLF & _
" fileprivate var overrideTabBarControllerDelegate: LUUITabBarControllerDelegate?" & @CRLF & _
" open override var tabBarControllerDelegate: UITabBarControllerDelegate? {" & @CRLF & _
" if overrideTabBarControllerDelegate == nil {" & @CRLF & _
" overrideTabBarControllerDelegate = WLTabBarControllerDelegate()" & @CRLF & _
" }" & @CRLF & _
" return overrideTabBarControllerDelegate" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" @objc open override func applyAppearance() {" & @CRLF & _
" super.applyAppearance()" & @CRLF & _
" WLAppearance.apply()" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" // swiftlint:disable:next function_body_length" & @CRLF & _
" @objc open override func configureApplicationKeys() {" & @CRLF & _
" let appConfig: LUUIApplicationConfiguration = LUUIApplicationConfiguration.shared()" & @CRLF & _
"" & @CRLF & _
" appConfig.crashlyticsAPIKey = WLCrashlyticsAPIKey" & @CRLF & _
" appConfig.googleAnalyticsTrackingID = WLGoogleAnalyticsTrackingID" & @CRLF & _
" appConfig.inviteFriendsShowsQRCode = true" & @CRLF & _
" appConfig.referAFriendCampaignID = NSNumber(value: WLReferAFriendCampaignID)" & @CRLF & _
" appConfig.usesSideNavigation = false" & @CRLF & _
" appConfig.enablePaymentPreferenceSelection = true" & @CRLF & _
" appConfig.sendGiftCardFromSettings = true" & @CRLF & _
" appConfig.claimBankingEnabled = true" & @CRLF & _
" appConfig.showEnableLocationAlert = true" & @CRLF & _
" appConfig.enableFacebookLogin = true" & @CRLF & _
" appConfig.myRewardsEnabled = true" & @CRLF & _
" appConfig.showOptionalInfoDuringRegistration = true" & @CRLF & _
" appConfig.analyticsConfiguration = analyticsConfiguration()" & @CRLF & _
" appConfig.cardReaderConfiguration = cardReaderConfiguration()" & @CRLF & _
" appConfig.appLocationsScreen = .mapLocations" & @CRLF & _
" appConfig.allowsOrderAhead = true" & @CRLF & _
" appConfig.enableOrderAheadLandingScreen = true" & @CRLF & _
" appConfig.allowsOrderAheadDelivery = false" & @CRLF & _
" appConfig.orderAheadMenuLayoutStyle = .list" & @CRLF & _
" appConfig.modularRewardsEnabled = true" & @CRLF & _
" appConfig.enableOrderAheadTipCell = false" & @CRLF & _
"" & @CRLF & _
" appConfig.levelupAPIKey = WLLevelUpAPIKey" & @CRLF & _
" appConfig.environmentConfigProd.levelupAppID = WLLevelUpAPIKey as NSString" & @CRLF & _
" appConfig.environmentConfigStaging.levelupAPIKey = WLLevelUpAPIKeyStaging as NSString" & @CRLF & _
"" & @CRLF & _
" appConfig.levelupAppID = WLLevelUpAppID" & @CRLF & _
" appConfig.environmentConfigProd.levelupAppID = WLLevelUpAppID as NSString" & @CRLF & _
" appConfig.environmentConfigStaging.levelupAppID = WLLevelUpAppIDStaging as NSString" & @CRLF & _
"" & @CRLF & _
" if WLLegacyLoyaltyCampaignID > 0 {" & @CRLF & _
" appConfig.loyaltyMigrationCampaignID = NSNumber(value: WLLegacyLoyaltyCampaignID)" & @CRLF & _
" appConfig.environmentConfigProd.loyaltyMigrationCampaignID = appConfig.loyaltyMigrationCampaignID!" & @CRLF & _
" appConfig.environmentConfigStaging.loyaltyMigrationCampaignID = NSNumber(value: WLLegacyLoyaltyCampaignIDStaging)" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" if WLReferAFriendCampaignID > 0 {" & @CRLF & _
" appConfig.referAFriendCampaignID = NSNumber(value: WLReferAFriendCampaignID)" & @CRLF & _
" appConfig.environmentConfigProd.referAFriendCampaignID = appConfig.referAFriendCampaignID!" & @CRLF & _
" appConfig.environmentConfigStaging.referAFriendCampaignID = NSNumber(value: WLReferAFriendCampaignIDStaging)" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" if let rewardsLoyaltyCampaignID: NSNumber = applicationConfig().rewardsLoyaltyCampaignID {" & @CRLF & _
" appConfig.rewardsLoyaltyCampaignID = rewardsLoyaltyCampaignID" & @CRLF & _
" appConfig.rewardsLoyaltyCampaignType = .spendBased" & @CRLF & _
" } else if WLRewardsLoyaltyCampaignID > 0 {" & @CRLF & _
" appConfig.rewardsLoyaltyCampaignID = NSNumber(value: WLRewardsLoyaltyCampaignID)" & @CRLF & _
" appConfig.environmentConfigProd.rewardsLoyaltyCampaignID = appConfig.rewardsLoyaltyCampaignID!" & @CRLF & _
" appConfig.environmentConfigStaging.rewardsLoyaltyCampaignID = NSNumber(value: WLRewardsLoyaltyCampaignIDStaging)" & @CRLF & _
" appConfig.rewardsLoyaltyCampaignType = .spendBased" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" if WLRewardsStatusCampaignID > 0 {" & @CRLF & _
" appConfig.rewardsStatusCampaignID = NSNumber(value: WLRewardsStatusCampaignID)" & @CRLF & _
" appConfig.environmentConfigProd.rewardsStatusCampaignID = appConfig.rewardsStatusCampaignID!" & @CRLF & _
" appConfig.environmentConfigStaging.rewardsStatusCampaignID = NSNumber(value: WLRewardsStatusCampaignIDStaging)" & @CRLF & _
" appConfig.rewardsStatusCampaignType = .spendBased" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" appConfig.analyticsConfiguration = analyticsConfiguration()" & @CRLF & _
" appConfig.cardReaderConfiguration = cardReaderConfiguration()" & @CRLF & _
" appConfig.crashReportingConfiguration = crashReportingConfiguration()" & @CRLF & _
" appConfig.viewControllerConfiguration = viewControllerConfiguration()" & @CRLF & _
" appConfig.viewConfiguration = viewConfiguration()" & @CRLF & _
" appConfig.cellConfiguration = cellConfiguration()" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" @objc open func analyticsConfiguration() -> LUUIAnalyticsConfiguration {" & @CRLF & _
" let analyticsConfig: LUUIAnalyticsConfiguration = LUUIAnalyticsConfiguration()" & @CRLF & _
" analyticsConfig.analyticsClass = WLAnalyticsWrapper.self" & @CRLF & _
" return analyticsConfig" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" @objc open func cardReaderConfiguration() -> LUUICardReaderConfiguration {" & @CRLF & _
" let cardReaderConfig: LUUICardReaderConfiguration = LUUICardReaderConfiguration()" & @CRLF & _
" cardReaderConfig.cardReaderViewControllerClass = WLCardReaderViewController.self" & @CRLF & _
" return cardReaderConfig" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" @objc open func crashReportingConfiguration() -> LUUICrashReportingConfiguration {" & @CRLF & _
" let crashReportingConfig: LUUICrashReportingConfiguration = LUUICrashReportingConfiguration()" & @CRLF & _
" crashReportingConfig.crashReportingWrapperClass = WLCrashlyticsWrapper.self" & @CRLF & _
" return crashReportingConfig" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" @objc open override func tabBarViewControllers() -> [Any]? {" & @CRLF & _
" return UITabBarController.loggedInTabBarController()" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" @objc open func viewConfiguration() -> LUUIViewConfiguration {" & @CRLF & _
" let config = LUUIViewConfiguration()" & @CRLF & _
"" & @CRLF & _
" config.imageRewardProgressionViewClass = WLImageRewardProgressionView.self" & @CRLF & _
"" & @CRLF & _
" return config" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" @objc open func viewControllerConfiguration() -> LUUIViewControllerConfiguration {" & @CRLF & _
" let config = LUUIViewControllerConfiguration()" & @CRLF & _
"" & @CRLF & _
" config.confirmGiftCardOrderViewControllerClass = WLConfirmGiftCardOrderViewController.self" & @CRLF & _
" config.forgotPasswordViewControllerClass = WLForgotPasswordViewController.self" & @CRLF & _
" config.getStartedViewControllerClass = WLGetStartedViewController.self" & @CRLF & _
" config.interstitialViewControllerClass = WLInterstitialViewController.self" & @CRLF & _
" config.inviteFriendsViewControllerClass = WLInviteFriendsViewController.self" & @CRLF & _
" config.logInViewControllerClass = WLLogInViewController.self" & @CRLF & _
" config.mapLocationsLocationDetailViewControllerClass = WLMapLocationsLocationDetailViewController.self" & @CRLF & _
" config.mapLocationsSearchViewControllerClass = WLMapLocationsSearchViewController.self" & @CRLF & _
" config.mapLocationsViewControllerClass = WLMapLocationsViewController.self" & @CRLF & _
" config.orderAheadLandingViewControllerClass = WLOrderAheadLandingViewController.self" & @CRLF & _
" config.orderGiftCardViewControllerClass = WLOrderGiftCardViewController.self" & @CRLF & _
" config.paymentMethodDetailViewControllerClass = WLPaymentMethodDetailViewController.self" & @CRLF & _
" config.payViewControllerClass = WLPayViewController.self" & @CRLF & _
" config.scanSuccessViewControllerClass = WLScanSuccessViewController.self" & @CRLF & _
" config.selectPaymentPreferenceViewControllerClass = WLSelectPaymentPreferenceViewController.self" & @CRLF & _
" config.settingsViewControllerClass = WLSettingsViewController.self" & @CRLF & _
" config.signUpViewControllerClass = WLSignUpViewController.self" & @CRLF & _
" config.signUpOrLogInViewControllerClass = WLSignUpOrLogInViewController.self" & @CRLF & _
" config.transactionDetailViewControllerClass = WLTransactionDetailViewController.self" & @CRLF & _
" config.transactionHistoryViewControllerClass = WLTransactionHistoryViewController.self" & @CRLF & _
" config.rewardsStatusLevelsViewControllerClass = WLRewardsStatusLevelsViewController.self" & @CRLF & _
" config.permissionPrimerViewControllerClass = WLPermissionPrimerViewController.self" & @CRLF & _
" config.selectPaymentMethodViewControllerClass = WLSelectPaymentMethodViewController.self" & @CRLF & _
" config.availableRewardsDrawerViewControllerClass = WLAvailableRewardsDrawerViewController.self" & @CRLF & _
" config.modularRewardsViewControllerClass = WLModularRewardsViewController.self" & @CRLF & _
"" & @CRLF & _
" return config" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" @objc open func cellConfiguration() -> LUUICellConfiguration {" & @CRLF & _
" let config = LUUICellConfiguration()" & @CRLF & _
"" & @CRLF & _
" config.captionedImageHeaderViewCellClass = WLCaptionedImageHeaderViewCell.self" & @CRLF & _
" config.locationCellClass = WLLocationCell.self" & @CRLF & _
" config.mapLocationsButtonsCellClass = WLMapLocationsButtonsCell.self" & @CRLF & _
" config.mapLocationsLocationCellClass = WLMapLocationsLocationCell.self" & @CRLF & _
" config.transactionEarnedCreditCellClass = WLTransactionEarnedCreditCell.self" & @CRLF & _
" config.transactionHistoryCellClass = WLTransactionHistoryCell.self" & @CRLF & _
" config.statusLevelGoalCellClass = WLStatusLevelGoalCell.self" & @CRLF & _
" config.availableRewardIconTableViewCellClass = WLAvailableRewardIconTableViewCell.self" & @CRLF & _
" config.orderAheadSpecialInstructionsCellClass = WLOrderAheadSpecialInstructionsCell.self" & @CRLF & _
" config.orderAheadCategoryMenuListTableViewCellClass = WLOrderAheadCategoryMenuListTableViewCell.self" & @CRLF & _
"" & @CRLF & _
" return config" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" @objc open override func settingsSectionsData() -> LUUIStaticTableViewData {" & @CRLF & _
" let data = LUUIStaticTableViewSectionsData()" & @CRLF & _
"" & @CRLF & _
" data.add(WLStaticTableViewSectionFactory.customSocialSection())" & @CRLF & _
" data.add(WLStaticTableViewSectionFactory.customAccountSection())" & @CRLF & _
" data.add(WLStaticTableViewSectionFactory.customHelpSection())" & @CRLF & _
"" & @CRLF & _
" return data" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")