$re = '/(?:(?<=^)|(?<=\s))([a-zA-Z0-9]+)(?:(?=\s)|(?=$))/m';
$str = 'we don\'t have 500 dollars
Your money\'s no good here, Mr. Torrance';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);