use strict;
my $str = '<?xml version="1.0" encoding="UTF-8"?>
<note>
<to>Tove</to>
<from>Jani</from>
<heading> * + Reminder + * </heading>
<body>Don\'t forget
me this weekend!
</body>
</note>
';
my $regex = qr/(?<=>)\s*([^<]*[^\s<])\s*(?=<)|(?<=>)\s*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";