import Foundation
let pattern = #"(?<=>)\s*([^<]*[^\s<])\s*(?=<)|(?<=>)\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<?xml version="1.0" encoding="UTF-8"?>
<note>
<to>Tove</to>
<from>Jani</from>
<heading> * + Reminder + * </heading>
<body>Don't forget
me this weekend!
</body>
</note>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)