package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b(\d+) ?m(?:m|illions?)?\b`)
var str = `I need $ 150000000, or 150 million,1 millions, 15 Million, 15million, 15Million, 15 m, 15 M, 15m, 15M, 15 MM, 15MM, 5 thousand`
var substitution = "\1000000"
fmt.Println(re.ReplaceAllString(str, substitution))
}