import Foundation
let pattern = #"(?i)\b(\d+) ?m(?:m|illions?)?\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"I need $ 150000000, or 150 million,1 millions, 15 Million, 15million, 15Million, 15 m, 15 M, 15m, 15M, 15 MM, 15MM, 5 thousand"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1000000"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)