import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/dignity-care-reports\\/[a-z-]+(\\/?)";
final String string = "/dignity-care-reports/\n"
+ "/dignity-in-care-reports/\n"
+ "/dignity-care-reports/buckingham/\n"
+ "/dignity-care-reports/winslow/\n"
+ "/dignity-care-reports/stoke-mandeville";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}