$re = '/^\/dignity-care-reports\/[a-z-]+(\/?)/m';
$str = '/dignity-care-reports/
/dignity-in-care-reports/
/dignity-care-reports/buckingham/
/dignity-care-reports/winslow/
/dignity-care-reports/stoke-mandeville';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);