using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^\w+\s)|(\d\?\(\w+\)\s)|(?:\d+\?$)";
string input = @"3A 4?(1) 5?(2) 6?(a) 7?(4) 8?(a) 9?(ii) 10?";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}