package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?):([0-9]+)\->[0-9]+\/([a-z]{3})`)
var str = ` Name Command State Ports
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
factorio_1 /docker-entrypoint.sh Up 0.0.0.0:27015->27015/tcp, 0.0.0.0:34197->34197/udp
minecraft_server /start Up (healthy) 0.0.0.0:25565->25565/tcp, 0.0.0.0:25565->25565/udp, 0.0.0.0:25575->25575/tcp, 0.0.0.0:25575->25575/udp
terraria_1 ./run.sh Up 0.0.0.0:7777->7777/tcp, 0.0.0.0:7777->7777/udp
ts3_db docker-entrypoint.sh mysqld Up 3306/tcp
ts3_server entrypoint.sh ts3server Up 0.0.0.0:10011->10011/tcp, 0.0.0.0:10022->10022/tcp, 0.0.0.0:10080->10080/tcp, 0.0.0.0:10443->10443/tcp, 0.0.0.0:30033->30033/tcp, 0.0.0.0:41144->41144/tcp, 0.0.0.0:9987->9987/udp`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}