import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "da\\s+Secretaria\\s+de\\s+Estado\\s+de\\s+Planejamento\\s+e\\s+Gestão";
final String string = "NOMEAR ISABELLE FERREIRA ZARONI, ID FUNCIONAL Nº\n"
+ "5100796-7, para exercer, com validade a contar de 16 de novembro\n"
+ "de 2020, o cargo em comissão de Assessor, símbolo DAS-7, da Sub-\n"
+ "secretaria de Concessões e Parcerias, da Secretaria de Estado de\n"
+ "Planejamento e Gestão, anteriormente ocupado por Vinicius dos San-\n"
+ "tos Silva, ID Funcional n° 5108029-0. Processo nº SEI-\n"
+ "1 2 0 0 0 1 / 0 1 4 6 11 / 2 0 2 0 .";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}