# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"da\s+Secretaria\s+de\s+Estado\s+de\s+Planejamento\s+e\s+Gestão"
test_str = ("NOMEAR ISABELLE FERREIRA ZARONI, ID FUNCIONAL Nº\n"
"5100796-7, para exercer, com validade a contar de 16 de novembro\n"
"de 2020, o cargo em comissão de Assessor, símbolo DAS-7, da Sub-\n"
"secretaria de Concessões e Parcerias, da Secretaria de Estado de\n"
"Planejamento e Gestão, anteriormente ocupado por Vinicius dos San-\n"
"tos Silva, ID Funcional n° 5108029-0. Processo nº SEI-\n"
"1 2 0 0 0 1 / 0 1 4 6 11 / 2 0 2 0 .")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.