re = /.*?(meta:.*").*/m
str = '<asp:Button ID="id1" runat="server" meta:resourceKey="ButtonTxt"/>
<asp:Label ID="id2" runat="server" meta:resourceKey="Name"></asp:Label>
<asp:Label ID="id3" runat="server" meta:resourcekey="Other_Name"></asp:Label>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end