package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)|\D+`)
var str = `123456
123-456
12-text
12-text-345
text-12-text-345`
var substitution = "$1\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}