use strict;
my $str = '123456
123-456
12-text
12-text-345
text-12-text-345';
my $regex = qr/(\d+)|\D+/mp;
my $subst = '$1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";