re = /^(redbook|bluepen|yellowglass)\s(greenapple\spinkglass|pinkglass\sgreenapple)$/m
str = 'bluepen pinkglass greenapple'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end