$re = '/(?<=\})[\s]*?\{.*?\}/ism';
$str = '{
color: red
}
a
{
color: red
} {
color: red
}
{
color: red
}
a
{
color: red
}
{
color: red
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);