#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s\"[^\"]+""
Local $sString = ""name": "john doe""
Local $sSubst = "xxx"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)