using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Igroup Name:\s+((?:[\w-]+,\s*)*[\w-]+)";
string input = @"Address: c8245A626
AliasName: eSrb002359_f1
Igroup Name: rtvclar002359, unjlclar002358-9,
cokeclar00RCB_FC
Protocol: REST";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}