package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?(DEFINE)
(?<chars>[-\w]) # equals to A-Z, a-z, 0-9, _
(?<af>=>) # "arrow function"
(?<item>
(?!(?&af)) # no af at the beginning
(?:(?&af)?(?&chars)++)+
(?!(?&af)) # no af at the end
)
)
^(?&item)$`)
var str = `Field_name_true2
abc=>d
=>abc
abc=>abc
somewhere_over_the_ocean=>
somewhere_over_the_ocean=>dda
somewhere-over-the-ocean
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}