package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"(test)"\h*:\h*(?|"([^"]*)"|\[([^]]*)])`)
var str = `"test":"value0"
"test":["value1", "value2"]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}