using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/(github\.com|meet\.jit\.si|example\.com|example\.net)|.*confluence.*";
string input = @"https://github.com
https://meet.jit.si
https://example.com
https://example.net
https://blah.confluence.blah.tld
https://anything.else.does.not.match
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}