$re = '/^[0-3][0-9][0-1][1-9][0-9]{2}[-\s][0-9]{4}$/m';
$str = 'WANT THIS:
100282 1187
100282-1187
NOT THIS:
1002821187
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);