#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)^([^\r\n]*)\r?\n(?=.*^\1(?:\r?\n|\z))"
Local $sString = "aaa" & @CRLF & _
"aaa" & @CRLF & _
"aaa" & @CRLF & _
"dsakjl dsa dlskj d aksdjkls djsa bbb" & @CRLF & _
"" & @CRLF & _
"dsakjl dsa dlskj d aksdjkls djsa" & @CRLF & _
"" & @CRLF & _
"bbb" & @CRLF & _
"aaa" & @CRLF & _
"" & @CRLF & _
"dsakjl dsa dlskj d aksdjkls djsa" & @CRLF & _
"dsjakldj lsajkl dsa dslkjkj ldsa"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)