import Foundation
let pattern = #"^([^\r\n]*)\r?\n(?=.*^\1(?:\r?\n|\z))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
aaa
aaa
aaa
dsakjl dsa dlskj d aksdjkls djsa bbb
dsakjl dsa dlskj d aksdjkls djsa
bbb
aaa
dsakjl dsa dlskj d aksdjkls djsa
dsjakldj lsajkl dsa dslkjkj ldsa
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)