import Foundation
let pattern = #"<p class="mb-40px">(?:<.+?>|\s)+?</p>\R*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
<p class="mb-40px"></g></svg> </a>
</li>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="comment-form-fields">
<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
<p class="comment-form-posting-as pa-wordpress">
Comentezi folosind contul tău WordPress.com. <span class="comment-form-log-out">
( <a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Dezautentificare</a> /
<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Schimbă</a> )
</span>
</p>
<p class="mb-40px">
Comentezi folosind contul tău Google. <span class="comment-form-log-out">
( <a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Dezautentificare</a> /
<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Schimbă</a> )
</span>
</p>
<p class="mb-40px">
Comentezi folosind contul tău Twitter. <span class="comment-form-log-out">
( <a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Dezautentificare</a> /
<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Schimbă</a> )
</span>
</p>
<p class="mb-40px">
Comentezi folosind contul tău Facebook. <span class="comment-form-log-out">
( <a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Dezautentificare</a> /
<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Schimbă</a> )
</span>
</p>
<p class="mb-40px">Foarte frumos lucru</p>
<p class="mb-40px">I love cars</p>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)