import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\[prev)( title=\"[^\"]+\")( cont=\"[^\"]+\" res=\"[^\"]+\")";
final String string = "[prev title=\"sample1\" cont=\"sample1a\" res=\"sample1b\" mw=\"1\"][prev title=\"sample2\" cont=\"sample2a\" res=\"sample2b\" mw=\"2\"][prev title=\"sample3\" cont=\"sample3a\" res=\"sample3b\" mw=\"3\"].";
final String subst = "$2$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}