use strict;
my $str = '[prev title="sample1" cont="sample1a" res="sample1b" mw="1"][prev title="sample2" cont="sample2a" res="sample2b" mw="2"][prev title="sample3" cont="sample3a" res="sample3b" mw="3"].';
my $regex = qr/(?<=\[prev)( title="[^"]+")( cont="[^"]+" res="[^"]+")/mp;
my $subst = '$2$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";