$re = '/^(?<client>.*)###(?<company>[^_]*)_(?<typology>[^_]*)_(?<period>[^_]*)_(?<uid>ID\d*)\.PdV$/mi';
$str = '0587###02511020162_LG_2019M01_ID4.PdV';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);