using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:'(.+?)(?<!\\)')";
string input = @"server ('m1.labs.teradata.com') username ('u\'se)r_*5') password('uer5') dbname ('default')";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}