use strict;
my $str = 'arandomsensitive information: 1234567890 this is not senstive: 1234567890000000';
my $regex = qr`\b(\d{4})\d{6}\b`mp;
my $subst = '$1******';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";