import Foundation
let pattern = #"\b(\d{4})\d{6}\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"arandomsensitive information: 1234567890 this is not senstive: 1234567890000000"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1******"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)