re = /(?:(?<=[\s,.:;"']|^)|\b)[0-9a-zа-яё]+(?:[.][0-9a-zа-яё]{2,})+(?:(?=[\s,.:;"']|$)|\b)/i
str = 'гугл.рус google.com jopa1.ru.com nick.name гугл.рус
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end