package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Z][a-z]{1,}) ([A-Z][a-z]{1,})`)
var str = `ivan ivanov
Ivan Ivanov
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}