#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^0-9\n]*[0-9]){2}.*"
Local $sString = "a 1 b 2 c" & @CRLF & _
"1 b 2 c" & @CRLF & _
"a 1 b 2" & @CRLF & _
"a 1 b 2 c 3 d 4 e" & @CRLF & _
"a 12" & @CRLF & _
"12 a b c" & @CRLF & _
"" & @CRLF & _
"a 1 b" & @CRLF & _
"1" & @CRLF & _
"a b 2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")