use strict;
my $str = 'a 1 b 2 c
1 b 2 c
a 1 b 2
a 1 b 2 c 3 d 4 e
a 12
12 a b c
a 1 b
1
a b 2';
my $regex = qr/^([^0-9\n]*[0-9]){2}.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}