import Foundation
let pattern = #"^[A-Z][A-Z]\d{3}\b\h+\S.*\s*(?>\RDate:\h+.*(?:\R(?!Date:|[A-Z][A-Z]\d{3}\b).*)*){2,}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
UM001 Uddharana Madhava
Date: 3/6/2021, Thursday
Topic: Bangla Economics
Language: Bengali
Date: 4/6/2021, Friday
Topic: Bangla Economics
Language: Bengali
Additional info: Extra session
Date: 3/6/2021, Thursday
Topic: Bangla Economics
Language: English
CJ009 Cidananda Janardana
Date: 3/6/2021, Thursday
Topic: Bangla Economics
Language: Telugu
VN019 Vrajanarayan
Date: 4/6/2021, Friday
Topic: Bangla Economics
Language: Telugu
Course Type: Free
Date: 5/6/2021, Saturday
Topic: Bangla Economics
Language: Telugu
Date: 4/6/2021, Friday
Topic: Bangla Economics
Language: Bengali
CJ009 Cidananda Janardana
Date: 3/6/2021, Thursday
Topic: Bangla Economics
Language: Telugu
CJ009 Cidananda Janardana
Date: 3/6/2021, Thursday
Topic: Bangla Economics
Language: Telugu
CJ009 Cidananda Janardana
Date: 3/6/2021, Thursday
Topic: Bangla Economics
Language: Telugu
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)