#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z]{4,8}[0-9]{0,4}$|^[a-z]{4,12}$"
Local $sString = "testtesttest" & @CRLF & _
"testtesttestr" & @CRLF & _
"test12345" & @CRLF & _
"testtest1234" & @CRLF & _
"testte123432" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")