package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z]{4,8}[0-9]{0,4}$|^[a-z]{4,12}$`)
var str = `testtesttest
testtesttestr
test12345
testtest1234
testte123432
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}