package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\S+) (\S+) (\S+) (\S+) (.+) (\S+) (\S+) (\S+) (\S+) (\S+) (\S+) (\S+)$`)
var str = `05/02/2018 L0007761 1 13640 Trust Printshop 8394BLK05 8394 BLACK L 104.00 16.77 83.88
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}