# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^((.+?)(another?|anoother?)(.+))$//gm;t' <<< "this is the anoother line\n
this is the another line\n
this is the anothe line\n
this is the other line\n"