package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((.+?)(another?|anoother?)(.+))$`)
var str = `this is the anoother line\n
this is the another line\n
this is the anothe line\n
this is the other line\n`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}