$re = '/^((.+?)(another?|anoother?)(.+))$/m';
$str = 'this is the anoother line\\n
this is the another line\\n
this is the anothe line\\n
this is the other line\\n';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;