// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((.+?)(another?|anoother?)(.+))$").unwrap();
let string = "this is the anoother line\\n
this is the another line\\n
this is the anothe line\\n
this is the other line\\n";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}